TrackEd

From PiBoSo Documentation
Jump to: navigation, search

Controls

Z key or MMB : pan
Mouse Wheel : Zoom in/out

3d View:

Right Ctrl key : Mouselook (hold)
Arrow Keys : Move
Mouse Wheel : Change movement speed

Cameras / Marshals Editor:

z key + left mouse button : move on the plane
x key + left mouse button : move up / down
c key + left mouse button : rotate camera

Menu

File

Load : Load a .trp file
Save : Save the currently open .trp file
Exit : Exit TrackEd


Centerline

New : Clear current editable centerline
Open : Load a centerline .tcl file
Save : Save currently open .tcl file
Save As : Save .tcl file
Scale : Scale entire centerline
Merge : 'Stamp' the currently editable centerline to the track mesh
Draw : Show / hide the centerline


View

Race Data : Dialogue for setting up track splits, pits, grid, etc.
Cameras Control : Place trackside cameras
Marshals : Place marshals (flags)
Layout : Place objects to block alternate routes


Draw

Draw Terrain : Show / hide the merged centerline and colour key overlay
Wireframe : Display track mesh with textures (no colour key)
Materials : Display material colour key overlay
Surfaces : Display physics surfaces colour key overlay
Draw Map : Show / hide the track geometry
Linear Guide : Show / hide the linear guide, if you have created one (linear guides can be created using the right click menu)


Background

Load
Set
Draw


Surface

Generate : Calculate the dynamic surface data
Edit : Adjust left and right borders
Draw : Show / hide the surface data


Bestline

Generate : Tool for generating a bestline
Save : Save bestline file
Draw : Turn display of bestline on or off


Min/Max Lines

Save
Draw
Min/Max Toggle : Show /hide the height window


Workflow

Load your track

  1. File -> Load, find your track .trp
  2. The file should load quickly. You will probably need to zoom out using the mouse wheel
  3. Hold the z key and move the mouse to pan around the viewport
  4. Go to the menu Draw -> Wireframe to see the track without collision colours

Create a centerline

  1. Centerline -> New
  2. Right click anywhere in the top window. Click New Segment
  3. From the menu that appears, select straight. Leave length at 10m. The first segment MUST be a straight!
  4. The first segment will be placed at world center. Move it to your startline position.
  5. Now is a good time to visually check your track scale. Your track should generally be around 12-14 metres wide. Kart tracks should generally be around 8m wide. If your track is not correctly scaled you will need to fix the size and re-export.
  6. Click and drag the start point of your first segment to the startline. The arrow indicates track direction.
  7. With your first segment selected, right click on it. Select Add Curve to add a curve segment. Drag the end of the curve around to follow your track centerline.
  8. Continue to add segments as needed to map out the entire track centerline. Try to use as few segments as possible.
  9. Make sure that the last segment is a curve.
  10. Move the endpoint of the last segment near to the startpoint of the first segment. Deselect segment by clicking away from the centerline, right click and choose close to close your centerline, making a complete loop. If your centerline will not close, add a second curve segment to the end and try again.
  11. It's a good idea to save your editable centerline to a .tcl file, so you can load it again if you re-export your trp. Go Centerline -> Save As
  12. Now you have a complete centerline, use Centerline -> Merge to 'stamp' it to the track.
  13. If you hide the editable purple centerline (Centerline -> Draw) you should be able to see the stamped red centerline.
  14. File -> Save to save the .trp file with the centerline included.
  15. If you reload your .trp now, you should be able to see your track with red centerline. The .trp is now prepared.

Race Data

The Race Data panel is used to place the grid, pits, and splits. When entering Left and Right values, the left value should be negative and the right positive.

Generate Bestline

Generate a bestline if you want to enable the yellow bestline helper, and to enable corner anticipation. This stage is not required.

Trackside Cameras

Place Cameras

  1. View -> Cameras Control to activate camera editing mode.
  2. Right click in the Cameras Control window and click Create Set
  3. Right click on the newly created Camera Set and click Rename if you like.
  4. Right click on your Camera Set and click edit
  5. Click on one of the New Camera buttons and then click in the scene to place it:
    1. Normal: Yellow. Standard camera, will look at the player.
    2. Fixed: Purple. Static camera. Will not rotate to follow player.
    3. Path: Red & Pink. Will move to follow player, between point 1 (Red) and point 2 (Pink).
  6. Click on the camera sphere in the scene to select it. You can right click on the camera in the list and select Locate to focus the view on the camera.
  7. Using the z (move horizontal), x (move vertical), c (rotate) keys, position your camera. If it is a Normal or Path camera, make sure it is angled perpendicular to the closest section of track.
  8. Right click on a camera and select Test to see from the camera's point of view. Left click to recenter view, right click to return.

Set Camera Limits

Sometimes you will find that a camera will activate at the wrong time. This can be fixed by using Limits. Right click on a camera sphere and select Edit. Tick the Enable checkbox in the Limit section. Now enter Start and End values - these correspond to distances along your track centerline. After clicking OK you will see green and red spheres appear on the track showing where the camera activation will start and end.

Autozoom

Autozoom is enabled by default. This zooms the camera when the target is far away.

  • Reference: The size of the target that the autozoom should try to maintain. 0.15 - 0.2 generally works best.
  • Min Fov: The minimum field of view allowed for the autozoom
  • Max Fov: The maximum field of view allowed for the autozoom

Generate Dynamic Surface

  1. Surface -> Generate to calculate the data. It may take several seconds, depending on track length.
  2. Surface -> Edit to adjust left and right borders to fit the racing surface as close as possible.

Add Objects to block off alternate layout routes

  1. View -> Layout to open the layout editor.
  2. Use RCtrl and the arrow keys to navigate the free roam camera
  3. Click on an object name in the Layout editor
  4. Click the Create button
  5. Click in the scene. The object will be placed on the ground below the cursor position
  6. Use the z (move horizontal) and c (rotate) keys to position the object
  7. Continue to add as many objects as necessary!
  8. Save the .lyt file!

Create Layouts

This is optional, if your track has multiple layouts.

  1. Create a new folder for your alternate layout inside your track folder (eg. tracks/mytrack/short/)
  2. Open your trp file in TrackEd, and either modify your existing centerline or create a new one from scratch.
  3. Merge the new centerline , generate a new dynamic surface (& bestline, if you want) and save the file as a new .trp in the alternate layout folder.
  4. Modify your trackside cameras to match the new layout, and save the .tsc file in the alternate layout folder.
  5. Modify your race data to match the new circuit length and save the .rdf in the alternate layout folder.
  6. Use the layout editor to place cones and haybales to block off routes. Save the .lyt in the alternate layout folder.
  7. Create a new map.tga image for the new layout
  8. Modify your marshals to fit the new layout and save the marshals.cfg file in the alternate layout folder.
  9. Copy your .ini file into the alternate layout folder, and modify appropriately.